Pre-requisites for Installing eG Agent

A set of pre-requsites should be fulfilled before you start deploying the eG agent. The requirements will vary based on the platform on which the eG agent is being installed. These requirements are discussed in the following sections.

For Windows Platforms

For the eG agent to function effectively, the system on which the agent is being installed should support:

  • Windows 2008 server (OR) Windows Vista (OR) Windows 7 (OR) Windows 8 (OR) Windows 2012 (OR) Windows 10 (OR) Windows 2016 (OR) Windows 2019
  • 512 MB RAM with at least 1 GB of disk space free for installing the agent

Note:

On Windows systems, the user account used to run the eG Agent on a system has to be a part of the local administrator group of that system. The two basic privileges that the user running the eG agent should have are “allow log on locally” and “log on as a service”. If the proper privileges are not provided to the user running the eG agent service, the eG agent will stop after running for a while.

For Unix Platform

For the eG agent to function effectively, the system on which the agent is being installed should support:

  • Solaris 7 (or higher), Red Hat Enterprise Linux v3 (or higher), AIX 4.3.3 (or higher), HP-UX 10 (or higher), FreeBSD 5.4, Tru64 5.1, openSUSE v11 (or above), CentOS v5.2 (or above), Fedora Linux, Oracle Linux v6.x (or higher), Ubuntu, Debian
  • 512 MB RAM and at least 1 GB of disk space for installing the agent

Note:

The eG agent software has to be installed from a super-user account.

As in the case of the manager, the procedure for installing an agent varies depending on the operating system environment used. Instructions for installing the agent on Solaris, Linux, AIX and HPUX operating systems are provided in the following sections.